Ubuntu ya tiene parches para solucionar Meltdown y Spectre

Son para el núcleo y el driver privativo Nvidia y pueden descargarse actualizando el sistema. Están disponibles para Ubuntu 17.10 (Artful Aardvark), Ubuntu 16.04 LTS (Xenial Xerus), y Ubuntu 14.04 LTS (Trusty Tahr).

¿Qué versiones del núcleo Linux y driver Nvidia están protegidas de Meltdown y Spectre?

Las siguientes versiones del núcleo Linux contienen los parches de seguridad:
linux-image 4.13.0.25.26 en Ubuntu 17.10, linux-image 4.4.0-108.131 en Ubuntu 16.04 LTS, linux-image 3.13.0.139.148 en Ubuntu 14.04 LTS, linux-image 4.4.0-108.131~14.04.1 en Ubuntu 14.04.5 LTS con núcleo Xenial HWE

En todos los casos si usas el controlador privativo Nvidia debes tener la versión 384.111.

¿Cómo saber si estoy protegido de Meltdown y Spectre?

Para saber que versión del núcleo tienes abre la terminal y escribe:
uname -r

Para ver que versión de driver Nvidia:
1) Abre la aplicación Software y Actualizaciones.
2) Pulsa en la pestaña Controladores Adicionales.

Comprobamos la versión instalada del driver Nvidia.

Cómo actualizar Ubuntu para instalar las actualizaciones para protegerse de Meltdown y Spectre

Para abrir el gestor de actualizaciones tenemos dos opciones:

1) Pulsa ALT+F2 y en la ventana que se abre escribe:
update-manager
Pulsa ENTER

2) En el lanzador busca la aplicación Actualización del software.

Ten presente que deberás reiniciar el sistema para que los cambios surtan efecto.
Más información

Anuncios

Deja un comentario