Instalar alguna de las versiones de Wine en Ubuntu 17.10 Artful Aadvark

Wine es una herramienta que permite utilizar aplicaciones de Windows en Linux. Tiene tres versiones; la estable, la versión en desarrollo y la versión que incorpora las novedades que en algún momento se integrarán a las otras dos. Esta es la forma de instalarla en Ubuntu 17.10 Artful Advark, versiones anteriores aún con soporte y derivadas.

1) Agregamos el soporte a la arquitectura de 64 bits.
sudo dpkg --add-architecture i386

2) Agregamos la clave de verificación.
wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key

3) Agregamos el repositorio.
Ubuntu: sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/
LinuxMint 17: sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ trusty main'
LinuxMint 18: sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main'

4) Actualizamos
sudo apt update

5) Instalamos la versión que queremos:

Estable
sudo apt install --install-recommends winehq-stable

Desarrollo
sudo apt install --install-recommends winehq-devel

Staging
sudo apt-get install --install-recommends winehq-staging

6) Corregimos errores de instalación
sudo apt-get install -f

Descargamos la aplicación de Windows que queremos utilizar (no todas son compatibles) y con el botón derecho elegimos abrirla con Wine. Este nos pedirá instalar componentes adicionales.

Publicidad

Anuncios

21 opiniones en “Instalar alguna de las versiones de Wine en Ubuntu 17.10 Artful Aadvark”

  1. Hmmm… bastante completo la verdad, aunque al final tengo un problema; luego de seguir todos los pasos, una dependencia está incumplida, la cual es: wine-stable (= 2.0.3~trusty)
    No seré un genio pero creo que usaré synaptic, a ver qué sale, si me funciona o no, he de comentarlo.

      1. Pues, me sale esto únicamente: Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
        libqt5declarative5 libqt5script5 qtquick1-qml-plugins
        Use ‘apt-get autoremove’ to remove them.

      1. Ahora me aparece esto: Los siguientes paquetes tienen dependencias incumplidas:
        wine-stable : Depende: wine-stable-i386 (= 2.0.3~trusty)
        E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
        Aunque al entrar a Synaptic no hay paquetes rotos ._.

      2. Pues sigue sin funcionar.
        Si necesitas saber qué hago exactamente puedo grabar para que veas y más o menos tengas una idea clara xD

      3. Ahora me acabo de dar cuenta que Launchpad no estaba funcionando. Espera a mañana y vuelve a probar.
        De hecho no sé que decirte porque a mi me pasaba lo mismo y se me solucionó haciendo lo del post que a ti te causa problemas.

      4. ¿En el tutorial original que repositorio usaste? Tienes que usar el que dice LinuxMint 17
        Ve a ORIGENES DE SOFTWARE OTRO SOFTWARE y desmarca los repositorios de wine, luego haz esto
        sudo apt-ger remove –purge wine-*
        Y luego repite los pasos del tutorial pero agregando el repositorio que dice LinuxMint 17

      5. Si, el estado de Launchpad no es muy bueno así que es normal que pase, ya me había pasado hace una semana atrás pero igual, pensé que era el SO que se estaba jodiendo xD
        ¡Gracias loco!
        Fuiste de bastante ayuda, sin ti habría pasado 1 mes buscando soluciones :’)

    1. Hola! Yo tengo el mismo problema que el compañero de arriba, uso Mint 18, así que he añadido el repo de Mint 18, pero no hay manera, siempre me da el mismo error que le daba a él.

Deja un comentario