PlanetaDiego pregunta: Particiones y enlaces simbólicos

Un lector me planteó la siguiente pregunta, dado que yo no tengo la menor idea de la respuesta se las traslado agradeciendo cualquier sugerencia en el formulario de comentarios.

“Tengo un SSD y un HDD en mi equipo. Ya desde Ubuntu 14.04 dejo la partición raíz y la home en el SSD y los datos los almaceno en una partición del HDD (en ext4) que montaba al inicio con las opciones en el fstab que recomienda juanetenbitel en su guía.

En Ubuntu 14.04 había borrado las carpetas de usuario de la /home (Vídeos, Música, Documentos…) y las había sustituído por enlaces simbólicos que apuntaban a las carpetas homónimas que tenía en el la partición de datos del HDD. Todo funcionaba perfectamente, como era de esperar: crear, modificar, enviar a la papelera, ningún problema.

Pero al actualizar a Ubuntu 16.04 ya no fue todo bien. La única diferencia importante respecto de la instalación de Ubuntu 14.04 es que no he hecho partición /home dedicada y he puesto la swap en el SSD (de ahí que no haya hecho /home dedicada, al poner la swap en el SSD no podía hacer más particiones), lo cual me pareció mucho mejor para aprovechar su velocidad (además, tengo 8GB de RAM y el funcionamiento de la swap es muy ocasional). El paricionado del SSD es el siguiente:

-partición reservada para sistema de Windows
-partición de Windows 10
-partición raíz de Ubuntu 16.04, en la cual está incluido el directorio /home.
-partición para SWAP

La partición de datos es la misma que ya tenía en Ubuntu 14.04 y, para montarla al inicio, me decanté por usar la herramienta de discos de Ubuntu; la partición se monta aparentemente sin problemas y parece funcionar bien (pero en lugar de hacerlo en /media lo hace en /mnt).

El problema vino cuando intenté hacer la misma operación de sustituír las carpetas de usuario por los enlaces simbólicos: puedo crear, modificar y eliminar archivos, pero no puedo enviarlos a la papelera, solo eliminarlos directamente.

Lo curioso de esto es que mientras los enlaces simbólicos estén en la misma partición donde están los datos a donde apuntan funcionan perfectamente. Solo hay problema cuando los muevo a mi espacio de usuario en la home, lo cual es, obviamente, lo que me interesa hacer. Empiezo a pensar que pudiera deberse al hecho de que la /home no sea una partición dedicada.

He pobado a cambiar las opciones de montaje, sustituyendo las que Ubuntu asigna por defecto por estas las que tenía en Ubuntu 14.04:

UUID=XXXXXXXXXXXX /media/carpeta_montaje ext4 errors=remount-ro 0 1

El problema es el mismo, con lo cual parece que no tiene que ver con las opciones de montaje. Tiene que ser otra cosa, por eso creo que puede ser debido a que la home no tenga partición dedicada.

He gugleado esto, pero no tengo muy claro como buscar y con las búsquedas que he intentado no ha habido suerte.

Finalmente me decidí por modificar el archivo user-dirs para que el destino de las carpetas de sistema apunte directamente a la partición de datos, pero me gustaría dejar el sistema igual que lo tenía, con enlaces simbólilcos, porque me parece bastante más intuitivo.”

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s